summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPekka Paalanen <pekka.paalanen@collabora.com>2021-02-08 16:29:51 +0200
committerPekka Paalanen <pekka.paalanen@collabora.com>2021-02-25 14:36:24 +0200
commit30104bd89ad7a1bcf8b75adf80343be5d172ceea (patch)
treee7f124d9bf1ce8fac1c7a0214fa1ccd55f661277 /meson.build
parent4b301fe7f27f97d3fd0ca587e8688032daf21dd6 (diff)
downloadweston-30104bd89ad7a1bcf8b75adf80343be5d172ceea.tar.gz
gl-renderer: support XYUV8888 wl_shm format
This support is added so that the XYUV shader variant can be tested with wl_shm from the test suite. Libwayland version requirement is bumped to get WL_SHM_FORMAT_XYUV8888. Libwayland is bumped to 1.18 too in the CI image. libwayland-dev package is dropped, because we build wayland anyway. Signed-off-by: Pekka Paalanen <pekka.paalanen@collabora.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 1b5c2e00..5a2db937 100644
--- a/meson.build
+++ b/meson.build
@@ -138,8 +138,8 @@ if dep_xkbcommon.version().version_compare('>= 0.5.0')
config_h.set('HAVE_XKBCOMMON_COMPOSE', '1')
endif
-dep_wayland_server = dependency('wayland-server', version: '>= 1.17.0')
-dep_wayland_client = dependency('wayland-client', version: '>= 1.17.0')
+dep_wayland_server = dependency('wayland-server', version: '>= 1.18.0')
+dep_wayland_client = dependency('wayland-client', version: '>= 1.18.0')
dep_pixman = dependency('pixman-1', version: '>= 0.25.2')
dep_libinput = dependency('libinput', version: '>= 0.8.0')
dep_libevdev = dependency('libevdev')