summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorSimon Ser <contact@emersion.fr>2021-02-16 13:34:46 +0100
committerDaniel Stone <daniels@collabora.com>2021-07-23 17:22:22 +0100
commit413d2104224d609c3f08be538d0e27d3295230ba (patch)
treeef87bd6ff6586a0ea810cb2ff47942ce4ee16b6f /meson.build
parent80e9482292437d4de84d234a3b847de345ce19af (diff)
downloadweston-413d2104224d609c3f08be538d0e27d3295230ba.tar.gz
libweston-desktop: introduce a deprecated-wl-shell option
This is the first step towards removing wl_shell support. Add an option so that users can toggle support for the deprecated wl_shell protocol. This lets users test their clients to make sure they work fine without wl_shell. The option is set to false by default. Signed-off-by: Simon Ser <contact@emersion.fr>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index f818ab19..78a4df93 100644
--- a/meson.build
+++ b/meson.build
@@ -139,6 +139,10 @@ if dep_xkbcommon.version().version_compare('>= 0.5.0')
config_h.set('HAVE_XKBCOMMON_COMPOSE', '1')
endif
+if get_option('deprecated-wl-shell')
+ config_h.set('HAVE_DEPRECATED_WL_SHELL', '1')
+endif
+
dep_wayland_server = dependency('wayland-server', version: '>= 1.18.0')
dep_wayland_client = dependency('wayland-client', version: '>= 1.18.0')
dep_pixman = dependency('pixman-1', version: '>= 0.25.2')