summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPekka Paalanen <pekka.paalanen@collabora.com>2022-05-20 14:29:47 +0300
committerPekka Paalanen <pq@iki.fi>2022-06-03 10:22:25 +0000
commit7fa9b153486edc6aa0ff53b91dad8e3aa6145768 (patch)
tree37f67713a1f8d99cf3d019b59281523d5a3a93f5 /meson.build
parent6234cb98d1b2b3b3cd39b18f69ee8cf4aa7efe32 (diff)
downloadweston-7fa9b153486edc6aa0ff53b91dad8e3aa6145768.tar.gz
build: consolidate lcms2 dependencies
It's bad form to set the same variable in multiple places, and not all of them were even equivalent. Move lcms2 finding to the root level build file only. It is still an optional dependency like before, and the if-not-found checks are still in place where actually needed. Signed-off-by: Pekka Paalanen <pekka.paalanen@collabora.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 47324bd8..994c7a56 100644
--- a/meson.build
+++ b/meson.build
@@ -158,6 +158,8 @@ if dep_libdrm_version.version_compare('>=2.4.107')
config_h.set('HAVE_HUMAN_FORMAT_MODIFIER', '1')
endif
+dep_lcms2 = dependency('lcms2', version: '>= 2.9', required: false)
+
prog_python = import('python').find_installation('python3')
files_xxd_py = files('tools/xxd.py')
cmd_xxd = [ prog_python, files_xxd_py, '@INPUT@', '@OUTPUT@' ]