summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPekka Paalanen <pekka.paalanen@collabora.com>2020-11-25 13:22:26 +0200
committerPekka Paalanen <pekka.paalanen@collabora.com>2021-02-25 13:16:02 +0200
commitd913363394fb8f9213a7627ee7b1c7b68b0287ec (patch)
tree1e719cb14da2cf69750bdd59358618f6146ec6de /meson.build
parent3ec25d781201bf3cb776b0428f29d0868c4a6006 (diff)
downloadweston-d913363394fb8f9213a7627ee7b1c7b68b0287ec.tar.gz
gl-renderer: move vertex shader into new file
This patch adds the tooling for incorporating files as C data, so that files can be built into the binaries. The tool is in Python to avoid adding extra dependencies like xxd. xxd.py is copied from Mesa as-is, from commit b729cd58d76f97f3fc04a67569535ee5ef2f5278 (master branch on 2021-01-26), a.k.a 21.0-branchpoint-635-gb729cd58d76. Moving the GLSL vertex shader into a separate file is not that interesting, the purpose of this commit is to provide a simple demonstration of the tooling. The real benefits come in a following patch where the fragment shaders are re-written and externalized. Signed-off-by: Pekka Paalanen <pekka.paalanen@collabora.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index fa828e4c..1b5c2e00 100644
--- a/meson.build
+++ b/meson.build
@@ -149,6 +149,10 @@ dep_libdrm = dependency('libdrm', version: '>= 2.4.95')
dep_libdrm_headers = dep_libdrm.partial_dependency(compile_args: true)
dep_threads = dependency('threads')
+prog_python = import('python').find_installation('python3')
+files_xxd_py = files('tools/xxd.py')
+cmd_xxd = [ prog_python, files_xxd_py, '@INPUT@', '@OUTPUT@' ]
+
subdir('include')
subdir('protocol')
subdir('shared')