summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNicolas Dufresne <nicolas.dufresne@collabora.co.uk>2010-08-26 11:29:12 -0400
committerNicolas Dufresne <nicolas.dufresne@collabora.co.uk>2010-10-04 12:53:45 -0400
commit668837041c03de92be41bd70247bde4b733dc6e8 (patch)
tree8d6a98793101e4de8c81c3cce254ee3dbaac329f /configure.ac
parent3d8bd1bd1e3857f1a14dbba92a8fe6bf7f790054 (diff)
downloadwocky-668837041c03de92be41bd70247bde4b733dc6e8.tar.gz
Added support for HTTP Connect Proxy
This patch registers an HTTP Connect extension to GLib proxy facility. This extension is triggered (whenever an HTTPS proxy is set) when legacy_ssl is being by providing a https:// base URI to the GSocketClient connect method.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9748fd0..95d3f90 100644
--- a/configure.ac
+++ b/configure.ac
@@ -114,6 +114,14 @@ PKG_CHECK_MODULES(GLIB, [glib-2.0 >= 2.16, gobject-2.0 >= 2.16, gthread-2.0 >=
AC_SUBST(GLIB_CFLAGS)
AC_SUBST(GLIB_LIBS)
+dnl Check GIO proxy support
+PKG_CHECK_EXISTS([gio-2.0 >= 2.25.15],
+ [HAVE_GIO_PROXY=yes
+ AC_DEFINE(HAVE_GIO_PROXY, [1], [Defined if GIO supports proxy])],
+ [HAVE_GIO_PROXY=no])
+AM_CONDITIONAL(HAVE_GIO_PROXY, [test "x${HAVE_GIO_PROXY}" = "xyes"])
+
+
dnl Choose an SSL/TLS backend (default gnutls)
AC_ARG_WITH([tls],
AC_HELP_STRING([--with-tls=BACKEND],