summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWill Thompson <will.thompson@collabora.co.uk>2012-12-12 15:56:03 +0000
committerWill Thompson <will.thompson@collabora.co.uk>2012-12-13 11:07:36 +0000
commitaaefe6f7bb05c1b6900586b6af20716dbd133f57 (patch)
treef989c584b7c76d49c78e425a7c4cbeb33959677c /configure.ac
parent9302f6b95002b4bb9c41bceb56e23d15d96875c7 (diff)
downloadwocky-aaefe6f7bb05c1b6900586b6af20716dbd133f57.tar.gz
Add optional libsoup dependency for google:relay
Sigh.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index cd01bca..636ed89 100644
--- a/configure.ac
+++ b/configure.ac
@@ -215,6 +215,19 @@ PKG_CHECK_MODULES(LIBIPHB, [libiphb >= 0.61.31],
AC_SUBST(LIBIPHB_CFLAGS)
AC_SUBST(LIBIPHB_LIBS)
+AC_ARG_ENABLE(google-relay,
+ AC_HELP_STRING([--disable-google-relay],
+ [disable Google Jingle relay support]),
+ [enable_google_relay=$enableval], [enable_google_relay=yes])
+
+if test x$enable_google_relay = xyes; then
+ AC_DEFINE(ENABLE_GOOGLE_RELAY, [], [Enable Google Jingle relay support])
+
+ dnl Check for libsoup
+ PKG_CHECK_MODULES(SOUP, libsoup-2.4)
+fi
+AM_CONDITIONAL([ENABLE_GOOGLE_RELAY], [test "x$enable_google_relay" = xyes])
+
AC_ARG_ENABLE(coverage, AC_HELP_STRING([--enable-coverage],
[compile with coverage profiling instrumentation (gcc only)]),
[
@@ -267,4 +280,5 @@ Configure summary:
SASL2 Tests..........: ${HAVE_LIBSASL2}
gtk-doc documentation: ${enable_gtk_doc}
libiphb integration..: ${have_iphb}
+ Google relay support.: ${enable_google_relay}
"