summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGeorge Kiagiadakis <gkiagia@tolabaki.gr>2016-07-03 21:20:56 +0300
committerGeorge Kiagiadakis <gkiagia@tolabaki.gr>2016-07-04 17:30:17 +0300
commitd54cde71584efcaf29dc76dff9125830929f5ad3 (patch)
tree72f77c3e74097a5ffc7703f626516ba23ac75dae /configure.ac
parent8708bcf3689ba3066fd4863636d038f6bc8d9eea (diff)
downloadwocky-d54cde71584efcaf29dc76dff9125830929f5ad3.tar.gz
Remove wocky-http-proxy, upstreamed in GIO now
The wocky http proxy has now moved in GIO, so we no longer need to maintain it here. I have kept the unit test for the moment, to verify that the code in gio works the same as the one that we used to ship in wocky. There was one difference in the code from GIO, though. It includes "Basic" as part of the authorization string. According to RFC this is correct, so it looks like the wocky proxy client code was doing this wrong. I have updated the test to reflect that. Additionally, this commit removes support for building GIO proxy support depending on whether GIO is recent enough or not. We can now safely depend unconditionally on a recent enough version. https://bugs.freedesktop.org/show_bug.cgi?id=94031 Reviewed-by: Diane Trout <diane@ghic.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 0 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 4e103ca..0e99203 100644
--- a/configure.ac
+++ b/configure.ac
@@ -127,14 +127,6 @@ AC_DEFINE([GLIB_VERSION_MAX_ALLOWED], [GLIB_VERSION_2_32], [Prevent post 2.32 AP
AC_SUBST(GLIB_CFLAGS)
AC_SUBST(GLIB_LIBS)
-dnl Check GIO proxy support
-PKG_CHECK_EXISTS([gio-2.0 >= 2.25.15],
- [HAVE_GIO_PROXY=yes
- AC_DEFINE(HAVE_GIO_PROXY, [1], [Defined if GIO supports proxy])],
- [HAVE_GIO_PROXY=no])
-AM_CONDITIONAL(HAVE_GIO_PROXY, [test "x${HAVE_GIO_PROXY}" = "xyes"])
-
-
dnl Choose an SSL/TLS backend (default gnutls)
AC_ARG_WITH([tls],
AC_HELP_STRING([--with-tls=BACKEND],