summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDafydd Harries <dafydd.harries@collabora.co.uk>2009-11-11 21:13:55 -0500
committerDafydd Harries <dafydd.harries@collabora.co.uk>2009-11-12 11:36:22 -0500
commitde59db1f75b7c1f54009f7d3e65c720893a7393a (patch)
tree840a91a10132401ac253be8d1c6338b6cb79c1bc /configure.ac
parent56c29352f61a95090b6bbe87dea0e8a388fbce54 (diff)
downloadwocky-de59db1f75b7c1f54009f7d3e65c720893a7393a.tar.gz
configure.ac: override official release logic
Because the current version, 0.0.0.0, ends in a zero, it's assumed that this is a release version, so -Werror is disabled. For now, just declare that it's not a release. Possibly an explicit release flag would be better than nano version which are always 0 or 1.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 4591ef1..e753191 100644
--- a/configure.ac
+++ b/configure.ac
@@ -34,9 +34,10 @@ AM_PROG_AS
AM_PROG_MKDIR_P
dnl decide error flags
-ifelse(wocky_nano_version, 0,
- [ official_release=yes ],
- [ official_release=no ])
+dnl ifelse(wocky_nano_version, 0,
+dnl [ official_release=yes ],
+dnl [ official_release=no ])
+official_release=no
TP_COMPILER_WARNINGS([ERROR_CFLAGS], [test "x$official_release" = xno],
[all \