summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarco Barisione <marco@barisione.org>2011-08-01 16:56:31 +0100
committerMarco Barisione <marco@barisione.org>2011-08-03 14:25:09 +0100
commite71f2054f4e6a593b9296ba761fcf6d94c8f980c (patch)
tree8e7eb3d8748d9cd9583383a105d720ed5f153c59 /configure.ac
parent4a16e1cb80ad124726f7e517b0d141bf5b921788 (diff)
downloadwocky-e71f2054f4e6a593b9296ba761fcf6d94c8f980c.tar.gz
configure: add an --enable-prefer-stream-ciphers option
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f2f5214..6f90c4f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -147,6 +147,16 @@ AC_SUBST(TLS_CFLAGS)
AC_SUBST(TLS_LIBS)
AM_CONDITIONAL(USING_OPENSSL, test x$USING_OPENSSL = xyes)
+AC_ARG_ENABLE([prefer-stream-ciphers],
+ AC_HELP_STRING([--enable-prefer-stream-ciphers],
+ [prefer stream ciphers over block ciphers to save bandwidth (at the possible expense of security)]),
+ [prefer_stream_ciphers=$enableval], [prefer_stream_ciphers=no])
+
+if test x$prefer_stream_ciphers = xyes; then
+ AC_DEFINE(ENABLE_PREFER_STREAM_CIPHERS, [],
+ [Prefer stream ciphers over block ones to save bandwidth])
+fi
+
GLIB_GENMARSHAL=`$PKG_CONFIG --variable=glib_genmarshal glib-2.0`
AC_SUBST(GLIB_GENMARSHAL)
@@ -232,6 +242,7 @@ Configure summary:
Features:
TLS Backend..........: ${with_tls}
+ Prefer stream ciphers: ${prefer_stream_ciphers}
SASL2 Tests..........: ${HAVE_LIBSASL2}
gtk-doc documentation: ${enable_gtk_doc}
libiphb integration..: ${have_iphb}