summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlexander Larsson <alexl@redhat.com>2015-05-28 22:02:31 +0200
committerAlexander Larsson <alexl@redhat.com>2015-05-28 22:02:31 +0200
commit2c0c21744fe50b5ab7e4c1262bdca20b2ee2b201 (patch)
tree495917cd5e11d85efcf2bc29ee611f0119b17fa3 /Makefile.am
parent8b7822ff07f2d6fd523973c495f2918900c2f7ca (diff)
downloadxdg-app-2c0c21744fe50b5ab7e4c1262bdca20b2ee2b201.tar.gz
helper: Drop setuid and use user namespaces
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 0 insertions, 10 deletions
diff --git a/Makefile.am b/Makefile.am
index e71ec3a..d7c9206 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -133,16 +133,6 @@ xdg_dbus_proxy_LDADD = $(BASE_LIBS) libglnx.la
xdg_dbus_proxy_CFLAGS = $(BASE_CFLAGS) -I$(srcdir)/libglnx
-install-exec-hook:
-if PRIV_MODE_SETUID
- $(SUDO_BIN) chown root $(DESTDIR)$(bindir)/xdg-app-helper
- $(SUDO_BIN) chmod u+s $(DESTDIR)$(bindir)/xdg-app-helper
-else
-if PRIV_MODE_FILECAPS
- $(SUDO_BIN) setcap cap_sys_admin+ep $(DESTDIR)$(bindir)/xdg-app-helper
-endif
-endif
-
completiondir = $(datadir)/bash-completion/completions
completion_DATA = completion/xdg-app
EXTRA_DIST += $(completion_DATA)