summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlexander Larsson <alexl@redhat.com>2016-04-29 11:39:39 +0200
committerAlexander Larsson <alexl@redhat.com>2016-04-29 15:52:44 +0200
commit4c3bf179e2e4a2a298cd1db1d045adaf3f564532 (patch)
treef0dfce3e32b0cdd2119b6bfd6860488aa5edcf5e /Makefile.am
parentee7be7f82dc72bc4bbbc9fce0ee66fa232baf7dc (diff)
downloadxdg-app-4c3bf179e2e4a2a298cd1db1d045adaf3f564532.tar.gz
Use bubblewrap instead of xdg-app-helper
Bubblewrap is a new tool from project atomic. Its similar to the old xdg-app-helper, but even more minimal, and a bit more generic. Its designed to be easy to git submodule install, but at some point we will probably support using the system installed version too. Using bubblewraps lets us share the load of security mainainance and allows other people to use bubblewrap to do their own unprivileged sandboxes.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 234177f..5e592a3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -35,7 +35,7 @@ AM_CPPFLAGS = \
-DXDG_APP_BASEDIR=\"$(pkgdatadir)\" \
-DXDG_APP_TRIGGERDIR=\"$(pkgdatadir)/triggers\" \
-DSYSTEM_FONTS_DIR=\"$(SYSTEM_FONTS_DIR)\" \
- -DHELPER=\"$(bindir)/xdg-app-helper\" \
+ -DHELPER=\"$(libdir)/xdg-app/bwrap\" \
-DDBUSPROXY=\"$(libexecdir)/xdg-dbus-proxy\" \
-DG_LOG_DOMAIN=\"xdg-app\" \
-I$(srcdir)/libglnx \