summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlexander Larsson <alexl@redhat.com>2015-05-29 10:46:10 +0200
committerAlexander Larsson <alexl@redhat.com>2015-05-29 10:46:10 +0200
commit50b3de3728ad5cb1042e44af4d3f5bbfdc19b239 (patch)
tree4fa40b8c8552ee46ce51e104e00b6b51148109ad /Makefile.am
parent31692b6ab23a7117901774214fabfab45eba69b9 (diff)
downloadxdg-app-50b3de3728ad5cb1042e44af4d3f5bbfdc19b239.tar.gz
helper: Optionally add back setuid support
If you don't have userns support in your kernel you can use this. The future lies with userns though, so it is the default.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index d7c9206..f593dd5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -132,6 +132,17 @@ xdg_dbus_proxy_SOURCES = \
xdg_dbus_proxy_LDADD = $(BASE_LIBS) libglnx.la
xdg_dbus_proxy_CFLAGS = $(BASE_CFLAGS) -I$(srcdir)/libglnx
+install-exec-hook:
+if DISABLE_USERNS
+if PRIV_MODE_SETUID
+ $(SUDO_BIN) chown root $(DESTDIR)$(bindir)/xdg-app-helper
+ $(SUDO_BIN) chmod u+s $(DESTDIR)$(bindir)/xdg-app-helper
+else
+if PRIV_MODE_FILECAPS
+ $(SUDO_BIN) setcap cap_sys_admin+ep $(DESTDIR)$(bindir)/xdg-app-helper
+endif
+endif
+endif
completiondir = $(datadir)/bash-completion/completions
completion_DATA = completion/xdg-app