summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlexander Larsson <alexl@redhat.com>2015-04-30 12:41:25 +0200
committerAlexander Larsson <alexl@redhat.com>2015-05-05 17:23:57 +0200
commit6048b38158cffc858d2f80a1b53854a74d214fdb (patch)
tree2514bb19ab4192ead20192dd511b1b0967f133b2 /Makefile.am
parentffb051b30d9332e068424cd6282f73ca45340d0b (diff)
downloadxdg-app-6048b38158cffc858d2f80a1b53854a74d214fdb.tar.gz
dbus proxy in progress
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index f4a5279..3feaf6c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -20,6 +20,10 @@ dist_triggers_SCRIPTS = \
triggers/desktop-database.trigger \
$(NULL)
+noinst_PROGRAMS = \
+ dbus-proxy \
+ $(NULL)
+
bin_PROGRAMS = \
xdg-app-helper \
xdg-app \
@@ -121,6 +125,14 @@ xdg_app_SOURCES = \
xdg_app_LDADD = $(BASE_LIBS) $(OSTREE_LIBS) $(SOUP_LIBS) libglnx.la
xdg_app_CFLAGS = $(BASE_CFLAGS) $(OSTREE_CFLAGS) $(SOUP_CFLAGS) -I$(srcdir)/libglnx
+dbus_proxy_SOURCES = \
+ dbus-proxy.c \
+ $(NULL)
+
+dbus_proxy_LDADD = $(BASE_LIBS)
+dbus_proxy_CFLAGS = $(BASE_CFLAGS)
+
+
install-exec-hook:
if PRIV_MODE_SETUID
$(SUDO_BIN) chown root $(DESTDIR)$(bindir)/xdg-app-helper