summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlexander Larsson <alexl@redhat.com>2015-05-06 12:38:52 +0200
committerAlexander Larsson <alexl@redhat.com>2015-05-06 12:38:52 +0200
commit7183917583b1356ba0b8edab6a4d86adcd3f4786 (patch)
treec3330e1fbe1f92138ae4b266937097de763b9e03 /Makefile.am
parentc0dca8dee43a6c13f2bdd930359dd67b27c6536e (diff)
downloadxdg-app-7183917583b1356ba0b8edab6a4d86adcd3f4786.tar.gz
Break out dbus proxy implementation to separate file
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 3feaf6c..f4ba632 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -43,6 +43,7 @@ include libglnx/Makefile-libglnx.am.inc
noinst_LTLIBRARIES = libglnx.la
xdg_app_helper_SOURCES = xdg-app-helper.c
+xdg_app_helper_LDADD = -L/gnome/lib -lglib-2.0
dbus_built_sources = xdg-app-dbus.c xdg-app-dbus.h
systemd_dbus_built_sources = xdg-app-systemd-dbus.c xdg-app-systemd-dbus.h
@@ -126,6 +127,8 @@ xdg_app_LDADD = $(BASE_LIBS) $(OSTREE_LIBS) $(SOUP_LIBS) libglnx.la
xdg_app_CFLAGS = $(BASE_CFLAGS) $(OSTREE_CFLAGS) $(SOUP_CFLAGS) -I$(srcdir)/libglnx
dbus_proxy_SOURCES = \
+ xdg-app-proxy.c \
+ xdg-app-proxy.h \
dbus-proxy.c \
$(NULL)