summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlexander Larsson <alexl@redhat.com>2015-07-10 16:46:27 +0200
committerAlexander Larsson <alexl@redhat.com>2015-07-10 16:56:39 +0200
commit929071ad1083494f717f6a5ab6dfcf817d143700 (patch)
tree0f01ac260bc5fe087bb478582f27cd6da832bbed /Makefile.am
parentb0e1124f0262d9d4cbfe9c6715eae3a3dcfb4875 (diff)
downloadxdg-app-929071ad1083494f717f6a5ab6dfcf817d143700.tar.gz
Import xdg-document-portal from github repo
This pulls in the daemon code from: https://github.com/alexlarsson/xdg-document-portal/ We need this in xdg-app because we need to set up the mounts correctly.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 0c235a7..c23cff8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,11 +3,20 @@ NULL =
bin_PROGRAMS = $(NULL)
libexec_PROGRAMS = $(NULL)
DISTCLEANFILES= $(NULL)
+BUILT_SOURCES = $(NULL)
if BUILD_DOCUMENTATION
SUBDIRS = doc
endif
+# D-BUS service file
+%.service: %.service.in config.log
+ $(AM_V_GEN) $(SED) -e "s|\@libexecdir\@|$(libexecdir)|" $< > $@
+
+servicedir = $(DBUS_SERVICE_DIR)
+service_in_files = $(NULL)
+service_DATA = $(NULL)
+
AM_CPPFLAGS = \
-DXDG_APP_BINDIR=\"$(bindir)\" \
-DXDG_APP_SYSTEMDIR=\"$(localstatedir)/xdg-app\"\
@@ -40,6 +49,7 @@ include lib/Makefile.am.inc
include app/Makefile.am.inc
include session-helper/Makefile.am.inc
include dbus-proxy/Makefile.am.inc
+include document-portal/Makefile.am.inc
completiondir = $(datadir)/bash-completion/completions
completion_DATA = completion/xdg-app