summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlexander Larsson <alexander.larsson@gmail.com>2015-05-19 18:17:20 +0200
committerAlexander Larsson <alexander.larsson@gmail.com>2015-05-19 18:17:20 +0200
commitea4adc2a8b771948c2ed56ff7f1ff6e5d77cca72 (patch)
tree1a1ff1eca51b541c6440e60f8961122a8280fed9 /Makefile.am
parent34f264e1f1b2adb086f04c03a503ab0cccf9ee4c (diff)
parent27fdae4153ce8b1f4fbd2304356f273fb3a3b9f9 (diff)
downloadxdg-app-ea4adc2a8b771948c2ed56ff7f1ff6e5d77cca72.tar.gz
Merge pull request #75 from amigadave/master
Add a simple profile.d snippet for XDG_DATA_DIRS
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 4c54f01..5b993a0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -146,3 +146,11 @@ endif
completiondir = $(datadir)/bash-completion/completions
completion_DATA = completion/xdg-app
EXTRA_DIST += $(completion_DATA)
+
+profiledir = $(sysconfdir)/profile.d
+profile_DATA = profile/xdg-app.sh
+EXTRA_DIST += profile/xdg-app.sh.in
+
+profile/xdg-app.sh: profile/xdg-app.sh.in
+ $(AM_V_GEN) $(SED) -e "s|\@localstatedir\@|$(localstatedir)|" \
+ -e "s|\@sysconfdir\@|$(sysconfdir)|" $< > $@