summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlexander Larsson <alexl@redhat.com>2016-02-09 15:02:56 +0100
committerAlexander Larsson <alexl@redhat.com>2016-02-09 15:02:56 +0100
commit0c9d1538c9060de817ff180c03298baa52f6a9e4 (patch)
treedca1f962152df42a7b788ce934604360ae630e8f /configure.ac
parent5dfc59ee023c4089efef712b44514a754116a917 (diff)
downloadxdg-app-0c9d1538c9060de817ff180c03298baa52f6a9e4.tar.gz
Add option to disable sandbox triggers
This is not something you should normally do, but the gnome-software app needs this, as recursive sandboxes don't work.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 91b6cdf..dd62dd2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -104,6 +104,16 @@ if test "x$enable_xauth" = "xyes"; then
[Define if using xauth])
fi
+AC_ARG_ENABLE([sandboxed-triggers],
+ AC_HELP_STRING([--disable-sandboxed-triggers],
+ [Disable sandboxed triggers]),
+ [],
+ [enable_sandboxed_triggers=yes])
+if test "x$enable_sandboxed_triggers" = "xno"; then
+ AC_DEFINE([DISABLE_SANDBOXED_TRIGGERS], [1],
+ [Define if sandboxed triggers are disabled])
+fi
+
PKG_CHECK_MODULES(OSTREE, [libgsystem >= 2015.1 ostree-1 >= 2015.3])
AC_SUBST(OSTREE_CFLAGS)
AC_SUBST(OSTREE_LIBS)