summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlexander Larsson <alexl@redhat.com>2015-12-16 15:19:32 +0100
committerAlexander Larsson <alexl@redhat.com>2015-12-16 15:27:42 +0100
commit570ba8b55fd06793f6f36d33faad84a2477a3a77 (patch)
tree83121ab5df2c52817fc3e36170ebc0d2d5bafab1 /configure.ac
parent619adeb74c6b7228c521f8855ca8d2ecde5728b5 (diff)
downloadxdg-app-570ba8b55fd06793f6f36d33faad84a2477a3a77.tar.gz
Add --enable-libxdgapp configure flag and disable lib by default
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d026965..1cdeab6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -117,6 +117,12 @@ if test "x$enable_seccomp" = "xyes"; then
fi
+AC_ARG_ENABLE(libxdgapp,
+ AS_HELP_STRING([--enable-libxdgapp],
+ [Install libxdg-app (default: no)]),,
+ [enable_libxdgapp=no])
+AM_CONDITIONAL(BUILDOPT_INSTALL_LIB, test x$enable_libxdgapp = xyes)
+
AC_ARG_ENABLE([userns],
AC_HELP_STRING([--disable-userns],
[Disable User namespaces (requires setuid/setcaps)]),