summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlexander Larsson <alexl@redhat.com>2015-03-06 11:26:07 +0100
committerAlexander Larsson <alexl@redhat.com>2015-03-06 11:26:07 +0100
commit957bf050bd3ae9362dbf9214e27af35708e7dfe3 (patch)
treedd6395302a6924c189f894cd50086dd0ba470d42 /configure.ac
parent5bfee405b17d9b5cc7133d17b44a7a27e1b5b69c (diff)
downloadxdg-app-957bf050bd3ae9362dbf9214e27af35708e7dfe3.tar.gz
Mount system fonts in /run/host/fonts
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 17a7179..193f76d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -34,6 +34,13 @@ AC_ARG_WITH(dbus_service_dir,
DBUS_SERVICE_DIR=$with_dbus_service_dir
AC_SUBST(DBUS_SERVICE_DIR)
+
+AC_ARG_WITH(system_fonts_dir,
+ AS_HELP_STRING([--with-system-fonts-dir=PATH],[Directory where system fonts are, [default=/usr/share/fonts]]),
+ with_system_fonts_dir="$withval", with_system_fonts_dir=/usr/share/fonts)
+SYSTEM_FONTS_DIR=$with_system_fonts_dir
+AC_SUBST(SYSTEM_FONTS_DIR)
+
AC_CHECK_HEADER([sys/capability.h], have_caps=yes, AC_MSG_ERROR([sys/capability.h header not found]))
AC_SUBST([GLIB_COMPILE_RESOURCES], [`$PKG_CONFIG --variable glib_compile_resources gio-2.0`])