summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon McVittie <smcv@debian.org>2016-01-29 09:41:23 +0100
committerSimon McVittie <smcv@debian.org>2016-01-29 09:41:23 +0100
commit9a6bf9505402df3e15541106ecf82dd48187d43b (patch)
tree677870f37699774dc50534eb85c854134d51216c /configure.ac
parenta754db12a2af47fde2cce8b330d9f402a0d8369f (diff)
downloadxdg-app-9a6bf9505402df3e15541106ecf82dd48187d43b.tar.gz
Disable gtkdoc-check by default for now
We know the documentation is incomplete, so there seems little value in having 'make check' tell us that. Everything except the documentation check is expected to succeed, so it's now more useful to report test failures in continuous integration systems, making functional regressions more visible. Signed-off-by: Simon McVittie <smcv@debian.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c1cfcfe..0a42b44 100644
--- a/configure.ac
+++ b/configure.ac
@@ -226,10 +226,18 @@ GOBJECT_INTROSPECTION_CHECK([1.40.0])
# gtkdocize greps for ^GTK_DOC_CHECK, so we need to put it on its own line
m4_ifdef([GTK_DOC_CHECK], [
GTK_DOC_CHECK([1.20], [--flavour no-tmpl])
+
+AC_ARG_ENABLE([gtk-doc-check],
+ [AS_HELP_STRING([--enable-gtk-doc-check],
+ [Check completeness of documentation in 'make check'])],
+ [],
+ [enable_gtk_doc_check=no])
],[
enable_gtk_doc="disabled (no gtk-doc)"
+enable_gtk_doc_check="disabled (no gtk-doc)"
AM_CONDITIONAL([ENABLE_GTK_DOC], [false])
])
+AM_CONDITIONAL([ENABLE_GTK_DOC_CHECK], [test "x$enable_gtk_doc_check" = xyes])
##################################################
# Visibility handling