summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlexander Larsson <alexl@redhat.com>2014-12-17 14:05:44 +0100
committerAlexander Larsson <alexl@redhat.com>2014-12-17 15:28:07 +0100
commita640cd365bd21743165adedb00bd9fac981687b2 (patch)
tree9783dbe0ab446c9946a7e9dd662903e005a3b5af /configure.ac
downloadxdg-app-a640cd365bd21743165adedb00bd9fac981687b2.tar.gz
Initial version
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac35
1 files changed, 35 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..7d08457
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,35 @@
+AC_PREREQ([2.63])
+
+AC_INIT([xdg-app],[0.0.1])
+
+AC_PROG_CC
+AM_PROG_CC_C_O
+AC_DISABLE_STATIC
+
+LT_PREREQ([2.2.6])
+LT_INIT([disable-static])
+
+AC_CONFIG_SRCDIR([xdg-app-helper.c])
+AC_CONFIG_HEADERS([config.h])
+AC_CONFIG_MACRO_DIR([m4])
+AM_INIT_AUTOMAKE([1.11 no-define no-dist-gzip dist-bzip2 tar-ustar foreign])
+
+# Enable silent rules is available
+AM_SILENT_RULES([yes])
+AM_MAINTAINER_MODE([enable])
+
+if test "x$GCC" = "xyes"; then
+ case " $CFLAGS " in
+ *[[\ \ ]]-Wall[[\ \ ]]*) ;;
+ *) CFLAGS="$CFLAGS -Wall" ;;
+ esac
+fi
+
+PKG_CHECK_MODULES(OSTREE, [glib-2.0 libgsystem gio-2.0 ostree-1])
+AC_SUBST(OSTREE_CFLAGS)
+AC_SUBST(OSTREE_LIBS)
+
+AC_CONFIG_FILES([
+Makefile
+])
+AC_OUTPUT