summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlexander Larsson <alexl@redhat.com>2016-04-20 12:05:32 +0200
committerAlexander Larsson <alexl@redhat.com>2016-04-28 20:29:49 +0200
commitc0f2304f8163d19548fd9ca11737d90cb912ad85 (patch)
treec13896582107d84b1778897edb121fb9b61e3099 /configure.ac
parentacd84a454aa6db429e0f0f87a2a958c8a7fcd1c7 (diff)
downloadxdg-app-c0f2304f8163d19548fd9ca11737d90cb912ad85.tar.gz
Experimental version of OCI support
This lets you export and import a runtime or an application into a tarball that explodes to match the oci runtime spec. This goal of this is to interchange xdg-app apps with other systems that support OCI. Note that this is highly experimental, because the oci specs are in flux, and in fact we should probably use the OCI image spec instead of the runtime spec, but its not yet finished enough for us to use it. So, don't rely on this for now other than to experiment with it.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1fef6f8..9c2110f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -140,8 +140,18 @@ PKG_CHECK_MODULES(OSTREE, [libgsystem >= 2015.1 ostree-1 >= 2016.5])
AC_SUBST(OSTREE_CFLAGS)
AC_SUBST(OSTREE_LIBS)
save_LIBS=$LIBS
+save_CFLAGS=$CFLAGS
LIBS=$OSTREE_LIBS
+CFLAGS=$OSTREE_CFLAGS
+
+AC_CHECK_MEMBER([OstreeRepoExportArchiveOptions.path_prefix],
+ [AC_DEFINE([HAVE_OSTREE_EXPORT_PATH_PREFIX], 1,
+ [Have OstreeRepoExportArchiveOptions.path_prefix])],
+ , [[#include <ostree.h>]])
+
LIBS=$save_LIBS
+CFLAGS=$save_CFLAGS
+
PKG_CHECK_MODULES(FUSE, [fuse])
AC_SUBST(FUSE_CFLAGS)