summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlexander Larsson <alexl@redhat.com>2016-05-18 11:11:03 +0200
committerAlexander Larsson <alexl@redhat.com>2016-05-18 11:11:03 +0200
commitc635633e6b36ec44a8baae7b50956f19cf44dd31 (patch)
tree9d479c2df97b3bf6257f4d67dd42a2e6901785a3 /configure.ac
parentc6486d01a21fabbfc3f0023d9e9e8c4a203d669e (diff)
downloadxdg-app-c635633e6b36ec44a8baae7b50956f19cf44dd31.tar.gz
Add --with-system-install-dir option0.6.0
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 66c3ea3..4c51c0f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -238,6 +238,14 @@ if test x$have_libelf != xyes; then
AC_MSG_ERROR([libelf not found])
fi
+AC_ARG_WITH(system-install-dir,
+ [AS_HELP_STRING([--with-system-install-dir=DIR],
+ [Location of system installation [LOCALSTATEDIR/lib/flatpak]])],
+ [],
+ [with_system_install_dir='$(localstatedir)/lib/flatpak'])
+SYSTEM_INSTALL_DIR=$with_system_install_dir
+AC_SUBST(SYSTEM_INSTALL_DIR)
+
dnl This only checks for the header, not the library.
AC_ARG_WITH([dwarf-header],
[AS_HELP_STRING([--with-dwarf-header],