summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlexander Larsson <alexl@redhat.com>2015-06-17 17:10:41 +0200
committerAlexander Larsson <alexl@redhat.com>2015-06-17 17:10:41 +0200
commitd52c09165c36a1f771d3e4db01cb18ac8fd75be6 (patch)
treeb0d97fd3f5cc9ea0cfd8f5b192170e65e0cc2eb1 /configure.ac
parent06cbbf99656fbf475ac5ecfaf53e0078b130ed81 (diff)
downloadxdg-app-d52c09165c36a1f771d3e4db01cb18ac8fd75be6.tar.gz
configure: Add checks for docbook xsl/dtd
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 526f60d..e429364 100644
--- a/configure.ac
+++ b/configure.ac
@@ -99,6 +99,20 @@ if test x$enable_documentation = xyes; then
if test x$XSLTPROC = x; then
AC_MSG_ERROR([xsltproc is required to build documentation])
fi
+
+ dnl check for DocBook DTD in the local catalog
+ JH_CHECK_XML_CATALOG([-//OASIS//DTD DocBook XML V4.1.2//EN],
+ [DocBook XML DTD V4.1.2], [have_docbook_dtd=yes], [have_docbook_dtd=no])
+ if test "$have_docbook_dtd" != yes; then
+ AC_MSG_ERROR([DocBook DTD is required for --enable-documentation])
+ fi
+
+ dnl check for DocBook XSL stylesheets in the local catalog
+ JH_CHECK_XML_CATALOG([http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl],
+ [DocBook XSL Stylesheets], [have_docbook_style=yes],[have_docbook_style=no])
+ if test "$have_docbook_style" != yes; then
+ AC_MSG_ERROR([DocBook XSL Stylesheets are required for --enable-documentation])
+ fi
fi
AM_CONDITIONAL(BUILD_DOCUMENTATION, test x$enable_documentation = xyes)