summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2015-12-04 14:57:20 +0000
committerEmmanuele Bassi <ebassi@gnome.org>2015-12-04 15:00:35 +0000
commitf23090a615bf829c4e3554da3ef4a12266fb5477 (patch)
tree600ab55bda7432f5293f0dd82a35e3f1b9f61bd2 /configure.ac
parent1647c85d6f841ea11ead214529f508c4ec69f966 (diff)
downloadxdg-app-f23090a615bf829c4e3554da3ef4a12266fb5477.tar.gz
Generate the API reference for libxdg-app
We use the good old gtk-doc.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 83a925e..273d54a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -194,6 +194,14 @@ AM_CONDITIONAL(BUILD_DOCUMENTATION, test x$enable_documentation = xyes)
GOBJECT_INTROSPECTION_CHECK([1.40.0])
+# gtkdocize greps for ^GTK_DOC_CHECK, so we need to put it on its own line
+m4_ifdef([GTK_DOC_CHECK], [
+GTK_DOC_CHECK([1.20], [--flavour no-tmpl])
+],[
+enable_gtk_doc="disabled (no gtk-doc)"
+AM_CONDITIONAL([ENABLE_GTK_DOC], [false])
+])
+
##################################################
# Visibility handling
##################################################
@@ -253,6 +261,7 @@ AC_SUBST(LT_CURRENT_MINUS_AGE)
AC_CONFIG_FILES([
Makefile
doc/Makefile
+doc/reference/Makefile
xdg-app.pc
lib/xdg-app-version-macros.h
])