summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2015-01-14 00:36:07 -0500
committerMatthias Clasen <mclasen@redhat.com>2015-01-14 01:38:49 -0500
commit2232a6d066bc06751c8d0af9fb2cf2a4d24c8bdb (patch)
treefe8b5f7790579dbd132a647ff197df7c1a557a5f /doc/Makefile.am
parent64fc43101dff5f90d39e872ecad9937e4345e666 (diff)
downloadxdg-app-2232a6d066bc06751c8d0af9fb2cf2a4d24c8bdb.tar.gz
Add man pages
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
new file mode 100644
index 0000000..43a7b6c
--- /dev/null
+++ b/doc/Makefile.am
@@ -0,0 +1,31 @@
+NULL =
+
+XSLTPROC_FLAGS = \
+ --nonet \
+ --stringparam man.output.quietly 1 \
+ --stringparam funcsynopsis.style ansi \
+ --stringparam man.th.extra1.suppress 1 \
+ --stringparam man.authors.section.enabled 0 \
+ --stringparam man.copyright.section.enabled 0 \
+ $(NULL)
+
+.xml.1:
+ $(AM_V_GEN) $(XSLTPROC) $(XSLTPROC_FLAGS) http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl $<
+
+man_MANS = \
+ xdg-app.1 \
+ xdg-app-add-repo.1 \
+ xdg-app-install-runtime.1 \
+ xdg-app-update-runtime.1 \
+ xdg-app-install-app.1 \
+ xdg-app-update-app.1 \
+ xdg-app-run.1 \
+ xdg-app-build-init.1 \
+ xdg-app-build.1 \
+ $(NULL)
+
+xml_files = $(man_MANS:.1=.xml)
+
+EXTRA_DIST = $(xml_files)
+
+DISTCLEANFILES = $(man_MANS)