summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBenedikt Meurer <benny@xfce.org>2005-08-11 16:57:06 +0000
committerBenedikt Meurer <benny@xfce.org>2005-08-11 16:57:06 +0000
commit25f30de4e6e451c0187b2d6de6bcca351c05ab32 (patch)
treeccb4c08c05c76c4e3ce45b07253d83e09e1c8098 /Makefile.am
parentfdb0add555fc4fd86406b034878417d0ac826074 (diff)
downloadthunar-25f30de4e6e451c0187b2d6de6bcca351c05ab32.tar.gz
2005-08-11 Benedikt Meurer <benny@xfce.org>
* thunar-vfs/thunar-vfs-mime-application.c (thunar_vfs_mime_application_new_from_desktop_id): Use "Name" instead of "GenericName" for the application's name, as the "Name" usually includes the project name in addition to the functional description of the application, which provides better results than having several applications named "Text Editor", etc. * configure.in.in: Prefer Gamin over FAM to avoid the C++ dependency if possible. Besides that, Gamin offers several other advantages over FAM, which makes it better suitable to be used in Thunar. * po/POTFILES.in: Add missing source files here, and remove obsolete files. * Thunar.desktop.in, Makefile.am, configure.in.in, po/POTFILES.in: Add desktop file for Thunar. (Old svn revision: 16851)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am25
1 files changed, 16 insertions, 9 deletions
diff --git a/Makefile.am b/Makefile.am
index 305702c6..5cbdcd8b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,15 +19,22 @@ rpm: dist
rpmbuild -ta $(PACKAGE)-$(VERSION).tar.gz
@rm -f $(PACKAGE)-$(VERSION).tar.gz
+desktopdir = $(datadir)/applications
+desktop_in_files = Thunar.desktop.in
+desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
+@INTLTOOL_DESKTOP_RULE@
+
EXTRA_DIST = \
- AUTHORS \
- COPYING \
- COPYING.LIB \
- ChangeLog \
- INSTALL \
- NEWS \
- README \
- THANKS \
- TODO
+ HACKING \
+ intltool-extract.in \
+ intltool-merge.in \
+ intltool-update.in \
+ $(desktop_in_files)
+
+DISTCLEANFILES = \
+ intltool-extract \
+ intltool-merge \
+ intltool-update \
+ $(desktop_DATA)
# vi:set ts=8 sw=8 noet ai nocindent syntax=automake: