summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorAli Abdallah <ali.abdallah@suse.com>2020-05-15 19:15:08 +0200
committerAli Abdallah <ali.abdallah@suse.com>2020-05-15 19:15:08 +0200
commit4e6286633205e07f80d1e0acbd8a1bb39af8b7aa (patch)
tree9be7291a02ac8dc1dc8520db88cf9134802d78e4 /tests/Makefile.am
parent6e4e3704f262e35c396ffa610538244b63115c29 (diff)
downloadxfconf-test-driver.tar.gz
Use a custom test-drivertest-driver
Implement a custom test driver that will start the freshly compiled xfconfd on a different dbus name. When the test finishes, gets interrupted or exists with error, the xfconfd test instance is terminated. This will allows 'make check' and 'make distcheck' to be successful even if xfconfd is not installed or running.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am8
1 files changed, 3 insertions, 5 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 57ba7e8..f1b06c0 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -5,12 +5,10 @@ SUBDIRS = \
get-properties \
reset-properties \
property-changed-signal \
- object-bindings
+ object-bindings \
+ tests-end
# list-channels
-clean-local:
- -rm -rf test-xdg_config_home
-
EXTRA_DIST = \
- $(test_scripts) \
+ tests-driver.sh \
tests-common.h