summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2021-01-08 14:33:56 +1000
committerSergey Udaltsov <sergey.udaltsov@gmail.com>2021-01-18 10:58:58 +0000
commit5dc9b48c9b31de9f9780887a79ded3b1e52591d9 (patch)
treed1482f67a6baeb6019d03bc4a58e2a20d1b03552 /meson.build
parenta9639617582bfc6ce81d9553d92dbea2ae80e061 (diff)
downloadxkeyboard-config-5dc9b48c9b31de9f9780887a79ded3b1e52591d9.tar.gz
gitlab CI: generate the evdev keycodes
The various <I123> keycodes in keycodes/evdev simply match the kernel defines + offset 8. There is no need to maintain these manually, let's generate them instead. Keycodes update rarely and irregularly (on average maybe every second kernel release) so there's no need to integrate this into the build itself, let's add it to our CI instead. The script here uses python-libevdev which has a list of the various key codes and their names (compile-time built-in in libevdev itself so it's advisable that a recent libevdev is used). The script is hooked up to a custom job that will fail if there are key codes with a #define in the kernel that are not listed in our evdev file. We allow that job to fail, it's not that urgent to prevent any other pipelines. Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 03cd953..ae46fb0 100644
--- a/meson.build
+++ b/meson.build
@@ -28,7 +28,7 @@ pkgconfig.generate(
# KcGST only need to be installed as-is
foreach dir: ['compat', 'geometry', 'keycodes', 'symbols', 'types']
install_subdir(dir,
- exclude_files: ['Makefile.am'],
+ exclude_files: ['Makefile.am', 'evdev.in'],
install_dir: dir_xkb_base)
endforeach