summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-06-29 23:04:46 +0000
committerSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-06-29 23:04:46 +0000
commit9ec316349f351f654a6bf9ac2492a5c7bfa87492 (patch)
treeef3bb76c531a1977db5f0779d0344763ff327747 /Makefile.am
parent4449eae1558daf1618ae9bcc2f53278bfc3e1fe2 (diff)
downloadxorg-app-xauth-9ec316349f351f654a6bf9ac2492a5c7bfa87492.tar.gz
Add xauth build system
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..1484cc9
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,36 @@
+#
+# Copyright 2005 Red Hat, Inc.
+#
+# Permission to use, copy, modify, distribute, and sell this software and its
+# documentation for any purpose is hereby granted without fee, provided that
+# the above copyright notice appear in all copies and that both that
+# copyright notice and this permission notice appear in supporting
+# documentation, and that the name of Red Hat not be used in
+# advertising or publicity pertaining to distribution of the software without
+# specific, written prior permission. Red Hat makes no
+# representations about the suitability of this software for any purpose. It
+# is provided "as is" without express or implied warranty.
+#
+# RED HAT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+# EVENT SHALL RED HAT BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+# DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+# PERFORMANCE OF THIS SOFTWARE.
+
+bin_PROGRAMS = xauth
+
+xauth_CFLAGS = $(DEP_CFLAGS)
+xauth_LDADD = $(DEP_LIBS)
+
+xauth_SOURCES = \
+ gethost.c \
+ parsedpy.c \
+ process.c \
+ xauth.c \
+ xauth.h
+
+dist_man_MANS = \
+ xauth.man
+