summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2006-12-11 18:48:54 -0800
committerAlan Coopersmith <alan.coopersmith@sun.com>2006-12-11 18:48:54 -0800
commitfa9b494baacab74d354ee4d5e0f6a1342b2bc723 (patch)
treecb142d7301c06c8fdf3a2f2aab9b14e1f0f5be56 /Makefile.am
parent2c2900cef3722580fa7b32721809365fad77348a (diff)
downloadxorg-app-xauth-fa9b494baacab74d354ee4d5e0f6a1342b2bc723.tar.gz
Replace static ChangeLog with disthook to generate from git log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 688af89..1e3b2f5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -38,7 +38,7 @@ appmandir = $(APP_MAN_DIR)
appman_DATA = $(appman_PRE:man=@APP_MAN_SUFFIX@)
-EXTRA_DIST = $(appman_PRE)
+EXTRA_DIST = $(appman_PRE) ChangeLog
CLEANFILES = $(appman_DATA)
SED = sed
@@ -64,3 +64,12 @@ SUFFIXES = .$(APP_MAN_SUFFIX) .man
.man.$(APP_MAN_SUFFIX):
sed $(MAN_SUBSTS) < $< > $@
+
+MAINTAINERCLEANFILES=ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog