summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJeremy Huddleston <jeremy@yuffie.local>2007-12-16 01:12:20 -0800
committerJeremy Huddleston <jeremy@yuffie.local>2007-12-16 01:12:20 -0800
commitcced740b1e1c8220701e59cec1be04498f851296 (patch)
tree8ec8a2cd170282ceef7bc420cbe396db24605a1b /Makefile.am
parent3c5ae3a242895f53d4f27fefb785f2725077a55d (diff)
downloadxorg-app-xinit-cced740b1e1c8220701e59cec1be04498f851296.tar.gz
OS-X: Added argv[0] hack for finding Xquartz UI and icon as well as claiming its dock icon
Partially removes need for x11-exec on OS-X. We still need to handle options set in defaults.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am22
1 files changed, 13 insertions, 9 deletions
diff --git a/Makefile.am b/Makefile.am
index fe39364..d170510 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -27,6 +27,10 @@ bin_SCRIPTS = startx
xinit_CFLAGS = $(XINIT_CFLAGS) -DXINITDIR=\"$(XINITDIR)\" -DBINDIR=\"$(bindir)\"
xinit_LDADD = $(XINIT_LIBS)
+if APPLE
+xinit_LDFLAGS = -framework CoreServices
+endif
+
xinit_SOURCES = \
xinit.c
@@ -54,14 +58,21 @@ PROGCPPDEFS = \
CPP_FILES_FLAGS = \
-DXINITDIR=$(XINITDIR) $(PROGCPPDEFS) -DLIBDIR=$(libdir) \
- -DSHELL_CMD=$(SHELL_CMD) $(STARTX_COOKIE_FLAGS)
+ -DSHELL_CMD=$(SHELL_CMD) $(STARTX_COOKIE_FLAGS) \
+ -D__libexecdir__="$(libexecdir)" \
+ -D__bindir__="$(bindir)"
+
+if LAUNCHD
+launchagents_PRE = org.x.X11.plist.pre
+launchagents_DATA = $(launchagents_PRE:plist.pre=plist)
+endif
xinitrc: xinitrc.cpp Makefile
startx: startx.cpp Makefile
xinitrc_DATA = xinitrc
-CLEANFILES = xinitrc startx $(appman_DATA)
+CLEANFILES = xinitrc startx $(appman_DATA) $(launchagents_DATA)
EXTRA_DIST = xinitrc.cpp startx.cpp $(appman_PRE) \
startx.cmd xinitrc.cmd xinit.def ChangeLog autogen.sh
@@ -72,10 +83,3 @@ ChangeLog:
(GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
dist-hook: ChangeLog
-
-if LAUNCHD
-LAUNCHD_SUBDIRS = launchd
-endif
-
-SUBDIRS = $(LAUNCHD_SUBDIRS)
-DIST_SUBDIRS = launchd