summaryrefslogtreecommitdiff
path: root/launchd/user_startx/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'launchd/user_startx/Makefile.am')
-rw-r--r--launchd/user_startx/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/launchd/user_startx/Makefile.am b/launchd/user_startx/Makefile.am
index ce00e73..bf18fb0 100644
--- a/launchd/user_startx/Makefile.am
+++ b/launchd/user_startx/Makefile.am
@@ -36,6 +36,10 @@ CPP_FILES_FLAGS = \
-D__bindir__="$(bindir)" \
-DBUNDLE_ID_PREFIX="$(bundleidprefix)"
+if LAUNCHAGENT_XSERVER
+CPP_FILES_FLAGS += -DLAUNCHAGENT_XSERVER_PATH="$(launchagentxserver)"
+endif
+
$(bundleidprefix).startx.plist.cpp: startx.plist.cpp
cp $< $@