summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Klausner <wiz@NetBSD.org>2013-07-29 23:23:47 +0200
committerGaetan Nadon <memsize@videotron.ca>2013-10-18 16:41:13 -0400
commit6042ab2647197d9aa09578ed1befe03931737f1c (patch)
tree30e90874a4ca3fc470780d26b464af32fb304634 /configure.ac
parent4f1a3cff9dfbfb33fcc6ff0a4ffd1db106301b97 (diff)
downloadxorg-driver-xf86-input-keyboard-6042ab2647197d9aa09578ed1befe03931737f1c.tar.gz
Add some NetBSD feature detection code.
Signed-off-by: Thomas Klausner <wiz@NetBSD.org> Reviewed-by: Matthieu Herrb <matthieu.herrb@laas.fr> Signed-off-by: Gaetan Nadon <memsize@videotron.ca>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c699f6e..27206c6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -79,6 +79,22 @@ case $host_os in
porting it.])
;;
esac
+case $host_os in
+ netbsd*)
+ case $host in
+ *powerpc-*|*sparc-*|*sparc64-*|*vax-*)
+ OS_FLAGS="$OS_FLAGS -DDEFAULT_TO_WSKBD"
+ ;;
+ esac
+ case "$(uname -m 2>&1)" in
+ evbarm|sgimips|shark)
+ OS_FLAGS="$OS_FLAGS -DDEFAULT_TO_WSKBD"
+ ;;
+ esac
+ ;;
+esac
+AC_SUBST([OS_FLAGS])
+
AM_CONDITIONAL(LINUX, [test "x$IS_LINUX" = xyes])
AM_CONDITIONAL(BSD, [test "x$IS_BSD" = xyes])
AM_CONDITIONAL(SOLARIS, [test "x$IS_SOLARIS" = xyes])