summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2020-05-19 16:30:11 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2020-05-19 16:30:35 +1000
commitf279108ffd07616299cf9fb922de14bd1249658d (patch)
tree7cc60427bf864383be220cdde6cc595b86eb5bac /configure.ac
parent583ed5acdc17a4dc7848c891d7cdbd35ff07b781 (diff)
downloadxorg-driver-xf86-input-libinput-f279108ffd07616299cf9fb922de14bd1249658d.tar.gz
Bump the libinput requirement to 1.11
Released June 2018, that should be recent enough. Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 1 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 6026197..bf65e90 100644
--- a/configure.ac
+++ b/configure.ac
@@ -45,22 +45,12 @@ XORG_DEFAULT_OPTIONS
# Obtain compiler/linker options from server and required extensions
PKG_CHECK_MODULES(XORG, [xorg-server >= 1.10] xproto [inputproto >= 2.2])
-PKG_CHECK_MODULES(LIBINPUT, [libinput >= 1.7.0])
+PKG_CHECK_MODULES(LIBINPUT, [libinput >= 1.11.0])
OLD_LIBS=$LIBS
OLD_CFLAGS=$CFLAGS
LIBS="$LIBS $LIBINPUT_LIBS"
CFLAGS="$CFLAGS $LIBINPUT_CFLAGS"
-AC_MSG_CHECKING([if libinput_device_touch_get_touch_count is available])
-AC_LINK_IFELSE(
- [AC_LANG_PROGRAM([[#include <libinput.h>]],
- [[libinput_device_touch_get_touch_count(NULL)]])],
- [AC_MSG_RESULT([yes])
- AC_DEFINE(HAVE_LIBINPUT_TOUCH_COUNT, [1],
- [libinput_device_touch_get_touch_count() is available])
- [libinput_have_touch_count=yes]],
- [AC_MSG_RESULT([no])
- [libinput_have_touch_count=no]])
AC_MSG_CHECKING([if libinput_device_config_scroll_get_button_lock is available])
AC_LINK_IFELSE(