summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2014-10-23 10:34:44 +0100
committerChris Wilson <chris@chris-wilson.co.uk>2014-11-06 16:55:46 +0000
commit87802b3402ec4a829c6507b4b78fcd03e30b6fe1 (patch)
treeb88ed62dc659cfb80fd92257cb9847323c71764e /configure.ac
parent33764685cbcd01548b6a23c217c7b511c1639694 (diff)
downloadxorg-driver-xf86-video-intel-87802b3402ec4a829c6507b4b78fcd03e30b6fe1.tar.gz
sna: Experimental support for write-combining mmaps
If we have a linear buffer, we can request the kernel mmap it directly with write-combining without having to pin it into the GTT. This allows us to efficiently upload very large buffers, and can avoid the dreaded aperture thrashing. Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8b34c773..75fd3b6f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -760,6 +760,16 @@ if test "x$RENDERNODE" = "xyes"; then
xp_msg="$xp_msg rendernode"
fi
+AC_ARG_ENABLE(wc-mmap,
+ AS_HELP_STRING([--enable-wc-map],
+ [Enable use of WriteCombining mmaps [default=no]]),
+ [WC_MMAP="$enableval"],
+ [WC_MMAP="no"])
+if test "x$WC_MMAP" = "xyes"; then
+ AC_DEFINE(USE_WC_MMAP,1,[Enable use of WriteCombining mmaps])
+ xp_msg="$xp_msg mmap(wc)"
+fi
+
AC_ARG_ENABLE(create2,
AS_HELP_STRING([--enable-create2],
[Enable use of create2 ioctl (experimental) [default=no]]),