summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2014-11-05 13:03:41 +0000
committerChris Wilson <chris@chris-wilson.co.uk>2014-11-19 13:15:36 +0000
commitb6eeb7a1f7efa591504070b606be655e27e6e9c2 (patch)
tree32015f171eed0b9a614c8b4814874d13697c85fc /configure.ac
parent6c2707d7bbc0ebb422be66618b6f78887c46446e (diff)
downloadxorg-driver-xf86-video-intel-b6eeb7a1f7efa591504070b606be655e27e6e9c2.tar.gz
Disable DRI3 by default
The external libraries, both in git, and especially shipping already enabled in distributions, are buggy and lead to server crashes and lockups. Caveat emptor. Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 328b4e99..cbfc4720 100644
--- a/configure.ac
+++ b/configure.ac
@@ -339,10 +339,10 @@ AC_ARG_ENABLE(dri2,
[DRI2=$enableval],
[DRI2=yes])
AC_ARG_ENABLE(dri3,
- AS_HELP_STRING([--disable-dri3],
- [Disable DRI3 support [[default=yes]]]),
+ AS_HELP_STRING([--enable-dri3],
+ [Enable DRI3 support [[default=no]]]),
[DRI3=$enableval],
- [DRI3=yes])
+ [DRI3=no])
AC_ARG_ENABLE(xvmc, AS_HELP_STRING([--disable-xvmc],
[Disable XvMC support [[default=yes]]]),