summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorBen Skeggs <bskeggs@redhat.com>2014-06-19 14:54:20 +1000
committerBen Skeggs <bskeggs@redhat.com>2014-06-19 14:54:20 +1000
commit5c44e6b86195c22e092db5dae06e70208e8b66a0 (patch)
tree9dcc0addf4c91a1da16b82d0c0dc0c12b92ed509 /src/Makefile.am
parentc375bacbdaeabd0288855c13b4717d0694be9e56 (diff)
downloadxorg-driver-xf86-video-nouveau-5c44e6b86195c22e092db5dae06e70208e8b66a0.tar.gz
pull copy engine handling into one place, a place that isn't also exa
As a side-effect, we now allow Kepler to use async copies too. Signed-off-by: Ben Skeggs <bskeggs@redhat.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 82d7c14..3c12e7e 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -30,6 +30,10 @@ nouveau_drv_la_LDFLAGS = -module -avoid-version @LIBDRM_NOUVEAU_LIBS@ \
nouveau_drv_ladir = @moduledir@/drivers
nouveau_drv_la_SOURCES = \
+ nouveau_copy.c \
+ nouveau_copy85b5.c \
+ nouveau_copy90b5.c \
+ nouveau_copya0b5.c \
nouveau_exa.c nouveau_xv.c nouveau_dri2.c \
nouveau_wfb.c \
nv_accel_common.c \
@@ -116,6 +120,7 @@ EXTRA_DIST = hwdefs/nv_3ddefs.xml.h \
shader/xfrm2nvf0.vpc \
shader/Makefile \
nouveau_local.h \
+ nouveau_copy.h \
nv_const.h \
nv_dma.h \
nv_include.h \