summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorBen Skeggs <bskeggs@redhat.com>2010-04-16 16:09:51 +1000
committerBen Skeggs <bskeggs@redhat.com>2010-04-16 16:45:33 +1000
commit6ff8ade0c7cd835b4172257ea310a8d88f28e757 (patch)
treefa82c0207d5b5926f88b34bb531caf6bb3476a72 /src/Makefile.am
parent4063616938f76af8028491276039d422c0782b1b (diff)
downloadxorg-driver-xf86-video-nouveau-6ff8ade0c7cd835b4172257ea310a8d88f28e757.tar.gz
Add uevent support
When a hotplug event is received from the kernel we should notify the client side to reconfigure the display. Ported to nouveau from radeon driver, based on work by ajax in intel driver.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index b5d287e..9340c45 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -23,9 +23,10 @@
# -avoid-version prevents gratuitous .0.0.0 version numbers on the end
# _ladir passes a dummy rpath to libtool so the thing will actually link
# TODO: -nostdlib/-Bstatic/-lgcc platform magic, not installing the .a, etc.
-AM_CFLAGS = @XORG_CFLAGS@ @LIBDRM_NOUVEAU_CFLAGS@
+AM_CFLAGS = @XORG_CFLAGS@ @LIBUDEV_CFLAGS@ @LIBDRM_NOUVEAU_CFLAGS@
nouveau_drv_la_LTLIBRARIES = nouveau_drv.la
-nouveau_drv_la_LDFLAGS = -module -avoid-version @LIBDRM_NOUVEAU_LIBS@
+nouveau_drv_la_LDFLAGS = -module -avoid-version @LIBDRM_NOUVEAU_LIBS@ \
+ @LIBUDEV_LIBS@
nouveau_drv_ladir = @moduledir@/drivers
nouveau_drv_la_SOURCES = \