summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorIlia Mirkin <imirkin@alum.mit.edu>2014-09-25 20:15:51 -0400
committerIlia Mirkin <imirkin@alum.mit.edu>2016-10-27 20:33:05 -0400
commita24ded627e42d453546c553d609edc073f59cd57 (patch)
tree1105451033aba017d59775d72cebe46521b8f315 /src/Makefile.am
parente6479845ec0db20dc733c621b7967b751840a552 (diff)
downloadxorg-driver-xf86-video-nouveau-a24ded627e42d453546c553d609edc073f59cd57.tar.gz
exa: add GM10x acceleration support
rendercheck -f a8r8g8b8 passes as much as on a GK208, and xv appears to work. Very lightly tested. Instead of sticking coordinates into pushbufs, the vertex shader is modified to read them from a constbuf, indexed by vertex id. This approach could be used for all nvc0 generations, but I didn't want to rock the boat. Signed-off-by: Ilia Mirkin <imirkin@alum.mit.edu> Reviewed-by: Samuel Pitoiset <samuel.pitoiset@gmail.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 1e04ddf..6ba8d87 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -77,48 +77,64 @@ EXTRA_DIST = hwdefs/nv_3ddefs.xml.h \
shader/exac8nve0.fpc \
shader/exac8nvf0.fp \
shader/exac8nvf0.fpc \
+ shader/exac8nv110.fp \
+ shader/exac8nv110.fpc \
shader/exacanvc0.fp \
shader/exacanvc0.fpc \
shader/exacanve0.fp \
shader/exacanve0.fpc \
shader/exacanvf0.fp \
shader/exacanvf0.fpc \
+ shader/exacanv110.fp \
+ shader/exacanv110.fpc \
shader/exacmnvc0.fp \
shader/exacmnvc0.fpc \
shader/exacmnve0.fp \
shader/exacmnve0.fpc \
shader/exacmnvf0.fp \
shader/exacmnvf0.fpc \
+ shader/exacmnv110.fp \
+ shader/exacmnv110.fpc \
shader/exas8nvc0.fp \
shader/exas8nvc0.fpc \
shader/exas8nve0.fp \
shader/exas8nve0.fpc \
shader/exas8nvf0.fp \
shader/exas8nvf0.fpc \
+ shader/exas8nv110.fp \
+ shader/exas8nv110.fpc \
shader/exasanvc0.fp \
shader/exasanvc0.fpc \
shader/exasanve0.fp \
shader/exasanve0.fpc \
shader/exasanvf0.fp \
shader/exasanvf0.fpc \
+ shader/exasanv110.fp \
+ shader/exasanv110.fpc \
shader/exascnvc0.fp \
shader/exascnvc0.fpc \
shader/exascnve0.fp \
shader/exascnve0.fpc \
shader/exascnvf0.fp \
shader/exascnvf0.fpc \
+ shader/exascnv110.fp \
+ shader/exascnv110.fpc \
shader/videonvc0.fp \
shader/videonvc0.fpc \
shader/videonve0.fp \
shader/videonve0.fpc \
shader/videonvf0.fp \
shader/videonvf0.fpc \
+ shader/videonv110.fp \
+ shader/videonv110.fpc \
shader/xfrm2nvc0.vp \
shader/xfrm2nvc0.vpc \
shader/xfrm2nve0.vp \
shader/xfrm2nve0.vpc \
shader/xfrm2nvf0.vp \
shader/xfrm2nvf0.vpc \
+ shader/xfrm2nv110.vp \
+ shader/xfrm2nv110.vpc \
shader/Makefile \
nouveau_local.h \
nouveau_copy.h \