summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMaarten Maathuis <madman2003@gmail.com>2008-05-05 01:26:37 +0200
committerMaarten Maathuis <madman2003@gmail.com>2008-05-05 01:26:57 +0200
commita7af057ff67cf5d7baf78d852dee5ac69b24e706 (patch)
tree0bf8cdf4aaa0428e377d1e89afc83ace8e6f4d9f /src/Makefile.am
parent5e1b5708d3a7e4298f80b1a1b8bb3fafae0c69bd (diff)
downloadxorg-driver-xf86-video-nouveau-a7af057ff67cf5d7baf78d852dee5ac69b24e706.tar.gz
NV50: Rework the modesetting code into a different model.
- There is now interface independent code for most things. - This structure, although not exclusive, is only used for NV50 atm. - The change in approach is that the concept of a connector is added to the model (randr12 sucks in this aspect). - I'm hacking around randr trying to create a single output for each connector, the indices are the bus numbers. - Limitations: Hot swapping vga and dvi of same monitor will not make randr12 think it changed, so for the moment force a change. - Concept is largely inspired by the radeonhd driver.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 762d74b..339899c 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -78,6 +78,13 @@ nouveau_drv_la_SOURCES = \
nv50_exa.c \
nv50_output.c \
nv50_sor.c \
+ nv50_randr.c \
+ nv50_randr.h \
+ nv50_connector.c \
nv50reg.h \
+ nouveau_crtc.h \
+ nouveau_output.h \
+ nouveau_connector.h \
+ nouveau_modeset.h \
nv_pcicompat.h