summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorBen Skeggs <skeggsb@gmail.com>2007-11-17 06:11:01 +1100
committerBen Skeggs <skeggsb@gmail.com>2007-11-17 09:53:52 +1100
commitddda33decb42ba2f5f9586e1d5de4533d1d88674 (patch)
tree9ae55c606c31ada99ed9a36715c47fbe13ef260f /src/Makefile.am
parent9b9d995a517b48cd074030c567f9c78bee19b129 (diff)
downloadxorg-driver-xf86-video-nouveau-ddda33decb42ba2f5f9586e1d5de4533d1d88674.tar.gz
Initial buffer object work.
Implemented on top of the current MM interface, and currently used in the exact same way NVAllocate/FreeMemory was used. Can transition to something more ttm-friendly gradually. The "old mm" bo backend is extremely primitive. Buffers can only be created in mappable memory, forcibly pinned, and never moved once they're created. Some of these things could be improved, but probably not much point.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index f9ba2ef..e07fae6 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -34,6 +34,7 @@ nouveau_drv_la_SOURCES = \
nouveau_grobj.c nouveau_grobj.h \
nouveau_notifier.c nouveau_notifier.h \
nouveau_dma.c nouveau_dma.h \
+ nouveau_bo.c nouveau_bo.h \
nouveau_class.h \
nv_accel_common.c \
nv_bios.c \
@@ -50,7 +51,6 @@ nouveau_drv_la_SOURCES = \
nv_include.h \
nv_dripriv.h \
nv_local.h \
- nv_mem.c \
nv_proto.h \
nvreg.h \
nv_setup.c \