summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorDaniel Stone <daniel@fooishbar.org>2010-06-15 18:48:48 +0100
committerDaniel Stone <daniel@fooishbar.org>2010-07-08 16:30:54 +0100
commit00175397480b76d32bf82b0c7c94c91a2a95954e (patch)
tree4dfe41d3a08c2b41ea07d5fa1704ad727c4f3350 /src/Makefile.am
parentebd6ef0a4db0ddef0ae17ad14571518ccdeea5ba (diff)
downloadxorg-lib-libX11-00175397480b76d32bf82b0c7c94c91a2a95954e.tar.gz
makekeys: Scan vendor keysyms as well as core
Since we can't really live without vendor keysyms, scan them all in to generate ks_tables.h, rather than only doing the core ones, and leaving the vendor syms to be manually synchronised with XKeysymDB. Signed-off-by: Daniel Stone <daniel@fooishbar.org> Reviewed-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 3140539e..735fd0cf 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -414,10 +414,10 @@ endif MAKE_LINT_LIB
# Building ks_tables.h requires the makekeys utility
#
-KEYSYMDEF=@KEYSYMDEF@
+KEYSYMDEFS=@KEYSYMDEFS@
-ks_tables.h: $(KEYSYMDEF) $(top_builddir)/src/util/makekeys$(EXEEXT)
- $(top_builddir)/src/util/makekeys < $(KEYSYMDEF) > ks_tables_h
+ks_tables.h: $(KEYSYMDEFS) $(top_builddir)/src/util/makekeys$(EXEEXT)
+ $(top_builddir)/src/util/makekeys $(KEYSYMDEFS) > ks_tables_h
mv ks_tables_h $@
$(top_builddir)/src/util/makekeys$(EXEEXT): force