summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJosh Triplett <josh@joshtriplett.org>2010-06-03 09:41:01 -0700
committerJosh Triplett <josh@joshtriplett.org>2010-06-03 22:19:14 -0700
commit15e5eaf62897b3179d1fbe457cb19f886f0449f8 (patch)
treed94b8749484b339c519803fb4b8bd1d82a64686f /src/Makefile.am
parentfb19eb767a32fd4ff74021c51bc6f60eb8bdff74 (diff)
downloadxorg-lib-libX11-15e5eaf62897b3179d1fbe457cb19f886f0449f8.tar.gz
Remove support for building without XCB
And there was much rejoicing. Signed-off-by: Josh Triplett <josh@joshtriplett.org> Reviewed-by: Jamey Sharp <jamey@minilop.net> Consensus on #xorg-devel agrees with removing --without-xcb; in particular, acks from Adam Jackson, Daniel Stone, Kristian Høgsberg, Julien Cristau, and Rémi Cardona.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am23
1 files changed, 6 insertions, 17 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 256e6f15..7cc1d164 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -3,7 +3,7 @@ XKB_SUBDIRS = xkb
endif
SUBDIRS = util xcms xlibi18n $(XKB_SUBDIRS)
-lib_LTLIBRARIES=libX11.la
+lib_LTLIBRARIES = libX11.la libX11-xcb.la
BUILT_SOURCES=ks_tables.h
CLEANFILES=ks_tables.h ks_tables_h
@@ -21,7 +21,6 @@ AM_CPPFLAGS= \
AM_CFLAGS= \
$(X11_CFLAGS) \
$(BIGFONT_CFLAGS) \
- $(XDMCP_CFLAGS) \
$(XMALLOC_ZERO_CFLAGS) \
$(CWARNFLAGS)
@@ -312,6 +311,8 @@ libX11_la_SOURCES = \
WMProps.c \
WrBitF.c \
Xatomtype.h \
+ xcb_disp.c \
+ xcb_io.c \
Xintatom.h \
Xintconn.h \
XlibAsync.c \
@@ -320,7 +321,8 @@ libX11_la_SOURCES = \
XomGeneric.h \
Xresinternal.h \
Xrm.c \
- XrmI.h
+ XrmI.h \
+ Xxcbint.h
#
# ========================= Extra stuff ============================
@@ -347,21 +349,9 @@ EXTRA_DIST = \
udcInf.c \
UIThrStubs.c
-if XCB
-libX11_la_SOURCES += \
- xcb_disp.c \
- xcb_io.c \
- Xxcbint.h
-
-lib_LTLIBRARIES += libX11-xcb.la
libX11_xcb_la_SOURCES = x11_xcb.c Xxcbint.h
libX11_xcb_la_LDFLAGS = -version-info 1:0:0 -no-undefined
libX11_xcb_la_LIBADD = libX11.la
-else
-libX11_la_SOURCES += \
- ConnDis.c \
- x11_trans.c
-endif
#
# Figure out which sub-libraries to link into Xlib
@@ -385,8 +375,7 @@ libX11_la_LIBADD = \
$(USE_I18N_LIBS) \
$(USE_XCMS_LIBS) \
$(USE_XKB_LIBS) \
- $(X11_LIBS) \
- $(XDMCP_LIBS)
+ $(X11_LIBS)
preprocess: $(patsubst %.c,%.ii,$(libX11_la_SOURCES))
.c.ii: