summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2013-11-15 18:03:25 -0800
committerAlan Coopersmith <alan.coopersmith@oracle.com>2016-02-03 21:58:24 -0800
commit3706b0f2b14cc97578a6bee620266edca2722ebf (patch)
tree429fd0c71f0a0dc41729e0a1a78d6eaea4bf83d4 /src/Makefile.am
parenteddf1bbd18872b286a9f939140f0cd9ba4e93804 (diff)
downloadxorg-lib-libX11-3706b0f2b14cc97578a6bee620266edca2722ebf.tar.gz
Don't need to link libX11-xcb against libX11
libX11-xcb only accesses data structures defined in X11 headers, it doesn't call any functions or reference any global variables in libX11 itself. (Seems to have been left from previous XCL implementation.) Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am1
1 files changed, 0 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index ceb83662..15de59bf 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -346,7 +346,6 @@ EXTRA_DIST = \
libX11_xcb_la_SOURCES = x11_xcb.c Xxcbint.h
libX11_xcb_la_LDFLAGS = -version-number 1:0:0 -no-undefined
-libX11_xcb_la_LIBADD = libX11.la
#
# Figure out which sub-libraries to link into Xlib