summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJeremy Huddleston <jeremyhu@freedesktop.org>2009-10-01 22:20:38 -0700
committerJeremy Huddleston <jeremyhu@freedesktop.org>2009-10-01 22:20:38 -0700
commit3bb020587ce74e0737ec7aceb20041f1e77d3b87 (patch)
tree6ca6a28d6099a09d11a74ab500fa77120157b2c8 /src/Makefile.am
parentd54caf1c9c55af8247621b7ba6afb20b23699839 (diff)
downloadxorg-lib-libX11-3bb020587ce74e0737ec7aceb20041f1e77d3b87.tar.gz
Split CFLAGS into CPPFLAGS and CFLAGS
On some build systems, CPPFLAGS is set to "-I/some/prefix/include". If older X11 headers are in /some/prefix/include, they will be preferred over the shipped headers. This corrects that problem.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 26d8e277..51e1e066 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -8,7 +8,7 @@ lib_LTLIBRARIES=libX11.la
BUILT_SOURCES=ks_tables.h
CLEANFILES=ks_tables.h ks_tables_h
-AM_CFLAGS= \
+AM_CPPFLAGS= \
-I$(top_srcdir)/include \
-I$(top_srcdir)/include/X11 \
-I$(top_builddir)/include \
@@ -16,10 +16,12 @@ AM_CFLAGS= \
-I$(top_srcdir)/src/xcms \
-I$(top_srcdir)/src/xkb \
-I$(top_srcdir)/src/xlibi18n \
+ -D_BSD_SOURCE -DX11_t -DTRANS_CLIENT
+
+AM_CFLAGS= \
$(X11_CFLAGS) \
$(BIGFONT_CFLAGS) \
$(XDMCP_CFLAGS) \
- -D_BSD_SOURCE -DX11_t -DTRANS_CLIENT \
$(XMALLOC_ZERO_CFLAGS)
#