summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJon Turney <jon.turney@dronecode.org.uk>2019-04-24 12:50:41 +0100
committerAlan Coopersmith <alanc.fdo@gmail.com>2019-06-08 23:58:16 +0000
commit6886d9ba06826785a8ccb312c04ea82b91bb6a25 (patch)
tree81e81c1a42968b12bbcbc3a8037811574e600fee /src/Makefile.am
parenta121b7b0c210efe10bf93453b29050282324c906 (diff)
downloadxorg-lib-libX11-6886d9ba06826785a8ccb312c04ea82b91bb6a25.tar.gz
Use EXEEXT_FOR_BUILD for makekeys
Use EXEXT_FOR_BUILD, to fix cross-compiling where EXEEXT differs from EXEEXT_FOR_BUILD, such as when building for Windows from unix. (Note: As written, this assumes EXEEXT_FOR_BUILD is always empty when cross-compiling. There could be some elaborate autodetection for EXEXT_FOR_BUILD, but for the moment, if you are cross-compiling from Windows to Unix, you'll need to set EXEEXT_FOR_BUILD explicity...)
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 80310069..7430bf41 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -413,9 +413,9 @@ endif MAKE_LINT_LIB
KEYSYMDEFS=@KEYSYMDEFS@
-ks_tables.h: $(KEYSYMDEFS) $(top_builddir)/src/util/makekeys$(EXEEXT)
+ks_tables.h: $(KEYSYMDEFS) $(top_builddir)/src/util/makekeys$(EXEEXT_FOR_BUILD)
$(top_builddir)/src/util/makekeys $(KEYSYMDEFS) > ks_tables_h
mv ks_tables_h $@
-$(top_builddir)/src/util/makekeys$(EXEEXT): $(top_builddir)/src/util/makekeys.c
+$(top_builddir)/src/util/makekeys$(EXEEXT_FOR_BUILD): $(top_builddir)/src/util/makekeys.c
cd util && $(MAKE)