summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2015-06-04 23:18:23 -0700
committerAlan Coopersmith <alan.coopersmith@oracle.com>2018-12-08 10:04:13 -0800
commitbcf7b5aa06c23aee00af7999b58cb96a8571ac42 (patch)
tree9edf012cc35ce19c8ff6bb4189f85e827c55d937 /src/Makefile.am
parent9bdfe9c9af11d77d66e5ff651e82b20e695cb460 (diff)
downloadxorg-lib-libX11-bcf7b5aa06c23aee00af7999b58cb96a8571ac42.tar.gz
Import reallocarray() from OpenBSD
Wrapper for realloc() that checks for overflow when multiplying arguments together, so we don't have to add overflow checks to every single call. For documentation on usage, see: http://www.openbsd.org/cgi-bin/man.cgi/OpenBSD-current/man3/calloc.3 Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index f8c476de..352d7ad0 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -366,6 +366,7 @@ endif
libX11_la_LDFLAGS = -version-number 6:3:0 -no-undefined
libX11_la_LIBADD = \
+ $(LTLIBOBJS) \
$(USE_I18N_LIBS) \
$(USE_XCMS_LIBS) \
$(USE_XKB_LIBS) \