summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2008-02-15 17:27:53 -0800
committerAlan Coopersmith <alan.coopersmith@sun.com>2008-02-15 17:27:53 -0800
commite5892467ae3308c8651be76e06db322dcbc08522 (patch)
treea6d52debf4f52ab36deea4cded9501d52eefca9f /src/Makefile.am
parente3eb83ec6a9bffa63cdffd94f077c12f85ad7240 (diff)
downloadxorg-lib-libX11-e5892467ae3308c8651be76e06db322dcbc08522.tar.gz
Add support for building lint library with --enable-lint-library
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 7c44f5b9..564e03f3 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -402,6 +402,19 @@ lint: $(BUILT_SOURCES)
done
endif LINT
+if MAKE_LINT_LIB
+lintlibdir = $(libdir)
+
+lintlib_DATA = $(LINTLIB)
+
+lintlib_src = $(libX11_la_SOURCES) xcms/*.c xkb/*.c
+
+CLEANFILES += $(lintlib_DATA)
+
+$(LINTLIB): $(libX11_la_SOURCES)
+ $(LINT) -y -oX11 -x $(ALL_LINT_FLAGS) $(lintlib_src)
+endif MAKE_LINT_LIB
+
#
# Building ks_tables.h requires the makekeys utility
#