summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJosh Triplett <josh@freedesktop.org>2006-10-05 17:44:22 -0700
committerJosh Triplett <josh@freedesktop.org>2006-10-05 17:44:22 -0700
commite754b3b078d556c7861da56aad47d244e9199e06 (patch)
tree45ad176d873ed26187289ad1e2fe1e5bd923f030 /src/Makefile.am
parentffd367f708b295abaedf3a23a1bfd4710d171d6f (diff)
downloadxorg-lib-libX11-e754b3b078d556c7861da56aad47d244e9199e06.tar.gz
Split public Xlib/XCB functions into libX11-xcb
We can never change the libX11 soname, and we don't want to commit to never changing the public Xlib/XCB functions, so split them into a separate library libX11-xcb. This also means that a program linked solely against libX11 should work with either Xlib or Xlib/XCB, which will make life easier for package maintainers. Signed-off-by: Josh Triplett <josh@freedesktop.org> Acked-by: Jamey Sharp <jamey@minilop.net>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 3c464709..6ab7412b 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -345,6 +345,11 @@ libX11_la_SOURCES += \
xcl/xcblock.c \
xcl/display.c \
xcl/io.c
+
+lib_LTLIBRARIES += libX11-xcb.la
+libX11_xcb_la_SOURCES = xcl/x11-xcb.c
+libX11_xcb_la_LDFLAGS = -version-info 1:0:0 -no-undefined
+libX11_xcb_la_LIBADD = libX11.la
else
libX11_la_SOURCES += \
ConnDis.c \